Welcome Guest [Log In] [Register]
Welcome to Nintendo 64 Forever. We hope you enjoy your visit.


You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are some features you can't use. If you join our community, you'll be able to access member-only sections, and use many member-only features such as customizing your profile, sending personal messages, and voting in polls. Registration is simple, fast, and completely free.


Join our community!


If you're already a member please log in to your account to access all of our features:

Username:   Password:
Add Reply
  • Pages:
  • 1
Need help getting Dexdrive to work
Topic Started: Dec 12 2015, 10:44 PM (1,821 Views)
Rocky
Member Avatar
Senior Member
For the life of me I can't get this to work. Here's some background info of my setup:

*OS: Windows 7
*I Bought this specific serial to usb adapter: http://tinyurl.com/q87o5la
*The usb adapter I bought came with the following driver that I'm currently using: Prolific USB-to-Serial Comm Port (COM2)
*I'm running Virtual PC with Windows 98
*I'm using Dexplorer 110.950 in the W98 VM


Here's what I did to try and get this working.

1. I installed the driver from the CD that came with my adapter.

2. I plugged in the adapter itself to finish the driver installation.

Posted Image

3. I went into my Virtual PC settings and set the COM 1 setting to ---> Physical Serial Port: COM2

Posted Image

4. I use the VM and go to launch Dexplorer and I get the "Dexdrive not Found" error.

Posted Image

Posted Image

Edited by Rocky, Dec 12 2015, 10:44 PM.
Posted Image
Offline Profile Quote Post Goto Top
 
bluedogrulez
Member Avatar
Racing for Fulcon Capital
Forgive the naive question, but have you confirmed that the dex is connected to the intended usb port?
Switch Friend Code: SW-0786-9287-1202 (bluedogBDR)
MK8Deluxe Tourney: N64Forever.com 2332-7277-8283
Nintendo Network ID: BDR2010 / Twitter: @bluedogrulez
Posted Image
Posted Image
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
bluedogrulez
Dec 12 2015, 10:51 PM
Forgive the naive question, but have you confirmed that the dex is connected to the intended usb port?
That's a good question....I'm not really sure? I haphazardly connected it to one of the ports on the back of my desktop.
Posted Image
Offline Profile Quote Post Goto Top
 
Pimpin Mainer
Member Avatar
When I shoot, I shoot to film
Hmm... This is a good question as I have purchased a Dex drive several months ago but have yet to set it up. I am running windows 10. Also Kartmaster had mentioned to me that he has some software to run the Dex drive, I wonder if its an updated version from the one that came in the box?
My Nintendo Collection

NES - 93
SNES - 45 N64 - 147 Game Cube - 5 Wii - 45 Switch - 11

Nintendo Friend Code: SW-8019-6333-1909

Posted Image
Offline Profile Quote Post Goto Top
 
Vinyl
Member Avatar
Veteran
Install the driver on the win98 system as well.

https://www.consolevariations.com/
The Ultimate Console Database

Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Offline Profile Quote Post Goto Top
 
Pimpin Mainer
Member Avatar
When I shoot, I shoot to film
Is there anyway to do this without having to run virtual console? Trying on windows 10 to save a glitched ghost for MK64. Time is of the essence as my memory card tends to erase itself every couple days.
My Nintendo Collection

NES - 93
SNES - 45 N64 - 147 Game Cube - 5 Wii - 45 Switch - 11

Nintendo Friend Code: SW-8019-6333-1909

Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
I currently have my dexdrive hooked up to a ye olden Windows 98 machine. It's not hooked up to the internet or anything, it's sole purpose is to use the DexDrive.

Let me mess around with my Windows 10 setup some and see if I can get something working.
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Pimpin Mainer
Member Avatar
When I shoot, I shoot to film
Thanks kartmaster! I've been doing a bunch of research and so far it looks like I need to buy an old PC lol.

Edit: Well I cont my PC to recognize the adapter for the DexDrive but not the device itself. Also my DexDrive's light doesn't turn on when plugged in. Does it only light up when transferring data? I hope its not broken as it came complete in a very nice box in good condition.
Edited by Pimpin Mainer, Dec 18 2015, 08:46 PM.
My Nintendo Collection

NES - 93
SNES - 45 N64 - 147 Game Cube - 5 Wii - 45 Switch - 11

Nintendo Friend Code: SW-8019-6333-1909

Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Okay, here's a link to the software I'm using on Win 10: http://web.bgwillers.com/Dexplorer_Win_10_OK.zip

I am hooking it to the built in serial port on my motherboard (No AC adapter connected to DexDrive).

Curiously, it didn't recognize my memory card when I first inserted it. How ever I formatted it and it seems to be reading and writing fine.

Here's a save I just made: http://web.bgwillers.com/Dex_Test.N64

And here's my COM Port Settings:
Bits per second: 9600
Data Bits: 8
Parity: None
Stop bits: 1
Flow control: None

Posted Image
Edited by kartmaster, Dec 21 2015, 07:58 PM.
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
kartmaster
Dec 21 2015, 07:56 PM
Okay, here's a link to the software I'm using on Win 10: http://web.bgwillers.com/Dexplorer_Win_10_OK.zip

I am hooking it to the built in serial port on my motherboard (No AC adapter connected to DexDrive).

Curiously, it didn't recognize my memory card when I first inserted it. How ever I formatted it and it seems to be reading and writing fine.

Here's a save I just made: http://web.bgwillers.com/Dex_Test.N64

And here's my COM Port Settings:
Bits per second: 9600
Data Bits: 8
Parity: None
Stop bits: 1
Flow control: None

Posted Image
Which Dexdrive program is that? Looks a lot newer than mine. :P Got a download link?
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
It's 2.00.902.

Link should be in my previous post. Let me know if it's not working!
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
kartmaster
Dec 21 2015, 08:06 PM
It's 2.00.902.

Link should be in my previous post. Let me know if it's not working!
Hmm, I have Windows 7...do you think your method will work on there?
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
I think so. The hangup for most people I think is getting a COM Port working on the newer OS. If you can get a functioning COM port, I think you'll be good to go!
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
kartmaster
Dec 21 2015, 08:14 PM
I think so. The hangup for most people I think is getting a COM Port working on the newer OS. If you can get a functioning COM port, I think you'll be good to go!
Sorry to bug ya. :P Did you have any troubles installing the program on Win10? Whenever I click on setup.exe nothing happens. When I click on autorun.exe I get a little menu with "Install Program" and "Read Me." When I click on Install Program it loads then the menu goes blank. I tried running with compatibility mode and administrator privileges with no luck.
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Hmm... I just ran the autorun. Didn't have to use any Compatability settings or anything.

Are you extracting it first, or trying to run it from within the Zip? Mine was already extracted if that is worth anything.
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
kartmaster
Dec 21 2015, 08:31 PM
Hmm... I just ran the autorun. Didn't have to use any Compatability settings or anything.

Are you extracting it first, or trying to run it from within the Zip? Mine was already extracted if that is worth anything.
It was already extracted. Hmm, I woulda figured since it works on Win10 that it would work on Win7. :-/
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Well, Win10 is a free upgrade. =)
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Hey, Rocky. I just downloaded an was able to install that version of Dexplorer on my Win7 64 bit machine at work with no problems.

I wish I knew why it's not working on yours. Have you checked your Event Viewer to see if there's any clues?
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
kartmaster
Dec 22 2015, 10:38 AM
Hey, Rocky. I just downloaded an was able to install that version of Dexplorer on my Win7 64 bit machine at work with no problems.

I wish I knew why it's not working on yours. Have you checked your Event Viewer to see if there's any clues?
Here's what Event Viewer said:

Log Name: Application
Source: Windows Error Reporting
Date: 12/22/2015 11:41:43 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: RockyP-PC
Description:
Fault bucket , type 0
Event Name: PCA2
Response: Not available
Cab Id: 0

Problem signature:
P1: Setup.exe
P2: 5.50.137.0
P3: 32-bit Setup Launcher
P4: InstallShield®
P5: InstallShield Software Corporation
P6: 200
P7: -1
P8:
P9:
P10:

Attached files:
C:\Users\Rocky\AppData\Local\Temp\{da2bc7a9-0797-4b26-875f-e09eb8ea6f0c}\appcompat.txt
C:\Users\Rocky\AppData\Local\Temp\Tab1C16.tmp

These files may be available here:


Analysis symbol:
Rechecking for solution: 0
Report Id: 42f8b208-a8d3-11e5-89f9-00ac9dcf8130
Report Status: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Windows Error Reporting" />
<EventID Qualifiers="0">1001</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2015-12-22T17:41:43.000000000Z" />
<EventRecordID>116759</EventRecordID>
<Channel>Application</Channel>
<Computer>RockyP-PC</Computer>
<Security />
</System>
<EventData>
<Data>
</Data>
<Data>0</Data>
<Data>PCA2</Data>
<Data>Not available</Data>
<Data>0</Data>
<Data>Setup.exe</Data>
<Data>5.50.137.0</Data>
<Data>32-bit Setup Launcher</Data>
<Data>InstallShield®</Data>
<Data>InstallShield Software Corporation</Data>
<Data>200</Data>
<Data>-1</Data>
<Data>
</Data>
<Data>
</Data>
<Data>
</Data>
<Data>
C:\Users\Rocky\AppData\Local\Temp\{da2bc7a9-0797-4b26-875f-e09eb8ea6f0c}\appcompat.txt
C:\Users\Rocky\AppData\Local\Temp\Tab1C16.tmp</Data>
<Data>
</Data>
<Data>
</Data>
<Data>0</Data>
<Data>42f8b208-a8d3-11e5-89f9-00ac9dcf8130</Data>
<Data>0</Data>
</EventData>
</Event>

------------------------------------------------------------------------

Log Name: Application
Source: Windows Error Reporting
Date: 12/22/2015 11:13:45 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: RockyP-PC
Description:
Fault bucket , type 0
Event Name: PCA2
Response: Not available
Cab Id: 0

Problem signature:
P1: AUTORUN.exe
P2: 1.0.0.1
P3: DexSetUp MFC Application
P4: DexSetUp Application
P5: Ȁɣ
P6: 1
P7: 200
P8:
P9:
P10:

Attached files:
C:\Users\Rocky\AppData\Local\Temp\{58877cf4-2250-45c0-86f6-9706eb95446f}\appcompat.txt

These files may be available here:
C:\Users\Rocky\AppData\Local\Microsoft\Windows\WER\ReportQueue\NonCritical_AUTORUN.exe_a638e2de521b2dbdc4faaace174dc71fdad11cf_cab_b9bd822b

Analysis symbol:
Rechecking for solution: 0
Report Id: 5adcb71d-a8cf-11e5-89f9-00ac9dcf8130
Report Status: 4
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Windows Error Reporting" />
<EventID Qualifiers="0">1001</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2015-12-22T17:13:45.000000000Z" />
<EventRecordID>116755</EventRecordID>
<Channel>Application</Channel>
<Computer>RockyP-PC</Computer>
<Security />
</System>
<EventData>
<Data>
</Data>
<Data>0</Data>
<Data>PCA2</Data>
<Data>Not available</Data>
<Data>0</Data>
<Data>AUTORUN.exe</Data>
<Data>1.0.0.1</Data>
<Data>DexSetUp MFC Application</Data>
<Data>DexSetUp Application</Data>
<Data>Ȁɣ</Data>
<Data>1</Data>
<Data>200</Data>
<Data>
</Data>
<Data>
</Data>
<Data>
</Data>
<Data>
C:\Users\Rocky\AppData\Local\Temp\{58877cf4-2250-45c0-86f6-9706eb95446f}\appcompat.txt</Data>
<Data>C:\Users\Rocky\AppData\Local\Microsoft\Windows\WER\ReportQueue\NonCritical_AUTORUN.exe_a638e2de521b2dbdc4faaace174dc71fdad11cf_cab_b9bd822b</Data>
<Data>
</Data>
<Data>0</Data>
<Data>5adcb71d-a8cf-11e5-89f9-00ac9dcf8130</Data>
<Data>4</Data>
</EventData>
</Event>

Edit: Just read the readme file and it says this:
Posted Image
Edited by Rocky, Dec 22 2015, 11:59 AM.
Posted Image
Offline Profile Quote Post Goto Top
 
Pimpin Mainer
Member Avatar
When I shoot, I shoot to film
I am having the same problem that Rocky is having. I am running Win 10 and I have extracted the files. When I run the autorun and I get the Dex installer app, but when I click install it seems to crash. This is the farthest I have come with this program so thanks kartmaster, almost there!

I did notice that when running compatibility (xp service pack 3) or as administrator the buttons will change to a purple color when clicked before freezing but without those settings the button doesn't change colors. seems like I'm getting closer. Too bad you cant run compatibility mode for Win ME or 98
Edited by Pimpin Mainer, Dec 22 2015, 12:09 PM.
My Nintendo Collection

NES - 93
SNES - 45 N64 - 147 Game Cube - 5 Wii - 45 Switch - 11

Nintendo Friend Code: SW-8019-6333-1909

Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Do either of you have Microsoft Visual C++ 2005 Redistributable installed?

If you don't, here's the link: https://www.microsoft.com/en-us/download/details.aspx?id=3387
Install that, then re-run the autorun (may need to reboot after C++ 2005 install).

If you already have that installed I'll have to dig deeper.
Edited by kartmaster, Dec 22 2015, 12:42 PM.
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Pimpin Mainer
Member Avatar
When I shoot, I shoot to film
Ill check it out kartmaster, again thanks for all your help!

Edit: well I tried installing C++ 2005 but it looks like I have C++ 2010 and it doesn't want to install an older version.
Edited by Pimpin Mainer, Dec 22 2015, 01:45 PM.
My Nintendo Collection

NES - 93
SNES - 45 N64 - 147 Game Cube - 5 Wii - 45 Switch - 11

Nintendo Friend Code: SW-8019-6333-1909

Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
kartmaster
Dec 22 2015, 12:39 PM
Do either of you have Microsoft Visual C++ 2005 Redistributable installed?

If you don't, here's the link: https://www.microsoft.com/en-us/download/details.aspx?id=3387
Install that, then re-run the autorun (may need to reboot after C++ 2005 install).

If you already have that installed I'll have to dig deeper.
I already had it. :o

Posted Image
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Hmmm... SOMETHING is different. I'm determined to find it! The people deserve the Dexdrive!
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Okay, a new option to try.

Download the 32bit Setup launcher here: http://toastytech.com/files/Is5Launcher.zip

REPLACE the Setup.exe file in the Dex_002_902 folder with the one you just downloaded.

After you've overwritten the old Setup.exe, Try installing the program by running the new Setup.exe.
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
No dice kartmaster. :(
Posted Image
Offline Profile Quote Post Goto Top
 
kartmaster
Member Avatar
Coffee Drinker
Drat. Do you have .NET installed?
Posted Image
Join in the N64 Forever MK64 Hotlap Competition!
Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
So. I ended up getting really frustrated trying to get this to work on Windows 7 so I thought the simplest solution would be to just buy a Win98 laptop! Or so I thought....

Posted Image

Posted Image

For some reason DexDrive is being weird saying it can't recognize my memory paks. I tried it with two different ones to no avail. I'm suspicous that it's the program/hardware at fault and not the memory packs.

Posted Image

Just to show that my memory packs aren't defective....Perfect Dark is showing my memories/blocks are indeed fine.

Posted Image

Any ideas!? This whole memory management thing with N64 is driving me bonkers. :blasphemy bat:
Posted Image
Offline Profile Quote Post Goto Top
 
Pimpin Mainer
Member Avatar
When I shoot, I shoot to film
Man, I was hoping to do the same thing and pick up and old PC to use my dex drive. It's kinda funny how hard it is to get this piece of tech working that's 10 plus years old. Someday Rocky we will be able to use these Dex Drives!
My Nintendo Collection

NES - 93
SNES - 45 N64 - 147 Game Cube - 5 Wii - 45 Switch - 11

Nintendo Friend Code: SW-8019-6333-1909

Posted Image
Offline Profile Quote Post Goto Top
 
Rocky
Member Avatar
Senior Member
Pimpin Mainer
Feb 24 2016, 09:53 PM
Man, I was hoping to do the same thing and pick up and old PC to use my dex drive. It's kinda funny how hard it is to get this piece of tech working that's 10 plus years old. Someday Rocky we will be able to use these Dex Drives!
One day Pimpin.......one day. ;_;
Posted Image
Offline Profile Quote Post Goto Top
 
DealsFor.me - The best sales, coupons, and discounts for you
Go to Next Page
« Previous Topic · Gaming & General Nintendo 64 Discussion · Next Topic »
Add Reply
  • Pages:
  • 1